summaryrefslogtreecommitdiffstats
path: root/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile12
-rw-r--r--web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile_mingw18
2 files changed, 30 insertions, 0 deletions
diff --git a/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile b/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile
new file mode 100644
index 00000000..0edaa7cb
--- /dev/null
+++ b/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile
@@ -0,0 +1,12 @@
+# Tested on FreeBSD, Ubuntu 10.04 and Cygwin
+CC=gcc
+CFLAGS=-c -Wall -std=c99 -pedantic
+LDFLAGS=-lcrypto -lssl
+
+all: test_client
+
+test_client: test_client.o openssl_hostname_validation.o
+ $(CC) test_client.o openssl_hostname_validation.o -o test_client $(LDFLAGS)
+
+clean:
+ rm -rf *.o test_client
diff --git a/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile_mingw b/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile_mingw
new file mode 100644
index 00000000..00f63144
--- /dev/null
+++ b/web/server/h2o/libh2o/deps/ssl-conservatory/openssl/Makefile_mingw
@@ -0,0 +1,18 @@
+# Tested on Windows 7 with MinGW-w64
+CC=gcc
+CFLAGS=-c -Wall
+LDFLAGS= -leay32 -lssl32
+
+all: test_client
+
+test_client: test_client.o openssl_hostname_validation.o
+ $(CC) test_client.o openssl_hostname_validation.o -o test_client $(LDFLAGS)
+
+test_client.o: test_client.c
+ $(CC) $(CFLAGS) test_client.c
+
+openssl_hostname_validation.o: openssl_hostname_validation.c
+ $(CC) $(CFLAGS) openssl_hostname_validation.c
+
+clean:
+ rm -rf *.o test_client.exe