summaryrefslogtreecommitdiffstats
path: root/web/server/h2o/libh2o/deps/yaml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--web/server/h2o/libh2o/deps/yaml/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/web/server/h2o/libh2o/deps/yaml/CMakeLists.txt b/web/server/h2o/libh2o/deps/yaml/CMakeLists.txt
new file mode 100644
index 00000000..e84c28cd
--- /dev/null
+++ b/web/server/h2o/libh2o/deps/yaml/CMakeLists.txt
@@ -0,0 +1,16 @@
+# Minimal CMake project for building a static library under Windows.
+
+cmake_minimum_required (VERSION 2.8)
+project (yaml C)
+
+set (YAML_VERSION_MAJOR 0)
+set (YAML_VERSION_MINOR 1)
+set (YAML_VERSION_PATCH 6)
+set (YAML_VERSION_STRING "${YAML_VERSION_MAJOR}.${YAML_VERSION_MINOR}.${YAML_VERSION_PATCH}")
+
+file (GLOB SRC src/*.c)
+
+include_directories (include win32)
+add_definitions (-DHAVE_CONFIG_H -DYAML_DECLARE_STATIC)
+add_library (yaml STATIC ${SRC})
+