summaryrefslogtreecommitdiffstats
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 06:03:02 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 06:03:02 +0000
commit4897093455a2bf08f3db3a1132cc2f6f5484d77c (patch)
tree9e6373544263f003139431fb4b08f9766e1ed530 /utils/Makefile.am
parentInitial commit. (diff)
downloadnfs-utils-4897093455a2bf08f3db3a1132cc2f6f5484d77c.tar.xz
nfs-utils-4897093455a2bf08f3db3a1132cc2f6f5484d77c.zip
Adding upstream version 1:2.6.4.upstream/1%2.6.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--utils/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
new file mode 100644
index 0000000..ab58419
--- /dev/null
+++ b/utils/Makefile.am
@@ -0,0 +1,47 @@
+## Process this file with automake to produce Makefile.in
+
+OPTDIRS =
+
+if CONFIG_NFSV4
+OPTDIRS += idmapd
+OPTDIRS += nfsidmap
+endif
+
+if CONFIG_NFSV4SERVER
+OPTDIRS += exportd
+endif
+
+if CONFIG_NFSV41
+OPTDIRS += blkmapd
+endif
+
+if CONFIG_GSS
+OPTDIRS += gssd
+endif
+
+if CONFIG_MOUNT
+OPTDIRS += mount
+endif
+
+if CONFIG_NFSDCLD
+OPTDIRS += nfsdcld
+endif
+
+if CONFIG_NFSDCLTRACK
+OPTDIRS += nfsdcltrack
+endif
+
+if CONFIG_JUNCTION
+OPTDIRS += nfsref
+endif
+
+SUBDIRS = \
+ exportfs \
+ mountd \
+ nfsd \
+ nfsstat \
+ showmount \
+ statd \
+ $(OPTDIRS)
+
+MAINTAINERCLEANFILES = Makefile.in