summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--debian/changelog7
-rw-r--r--debian/control2
-rw-r--r--debian/patches/reexport.c-Some-Distros-need-the-following-include-t.patch38
-rw-r--r--debian/patches/series1
4 files changed, 47 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 1d9d289..a0ede3d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+nfs-utils (1:2.6.4-5) unstable; urgency=medium
+
+ * Add missing #include <stddef.h> (Closes: #1073818)
+ * Declare compliance with Debian policy 4.7.0
+
+ -- Salvatore Bonaccorso <carnil@debian.org> Sat, 22 Jun 2024 11:50:22 +0200
+
nfs-utils (1:2.6.4-4~progress7.99u1) graograman-backports; urgency=medium
* Uploading to graograman-backports, remaining changes:
diff --git a/debian/control b/debian/control
index d0a3ec1..d058105 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ XSBC-Original-Maintainer: Debian kernel team <debian-kernel@lists.debian.org>
XSBC-Original-Uploaders: Anibal Monsalve Salazar <anibal@debian.org>, Ben Hutchings <benh@debian.org>, Steve Langasek <vorlon@debian.org>, Salvatore Bonaccorso <carnil@debian.org>
Bugs: mailto:maintainers@lists.progress-linux.org
Build-Depends: debhelper-compat (= 13), libwrap0-dev, libevent-dev, libkrb5-dev, libblkid-dev, libkeyutils-dev, pkg-config, libldap2-dev, libcap-dev, libtirpc-dev (>= 1.3.4), libdevmapper-dev, libmount-dev, libsqlite3-dev, libxml2-dev
-Standards-Version: 4.6.2
+Standards-Version: 4.7.0
Homepage: https://linux-nfs.org/
Vcs-Browser: https://git.progress-linux.org/packages/graograman-backports/nfs-utils
Vcs-Git: https://git.progress-linux.org/packages/graograman-backports/nfs-utils
diff --git a/debian/patches/reexport.c-Some-Distros-need-the-following-include-t.patch b/debian/patches/reexport.c-Some-Distros-need-the-following-include-t.patch
new file mode 100644
index 0000000..c1429fd
--- /dev/null
+++ b/debian/patches/reexport.c-Some-Distros-need-the-following-include-t.patch
@@ -0,0 +1,38 @@
+From: Steve Dickson <steved@redhat.com>
+Date: Mon, 22 Jan 2024 13:23:57 -0500
+Subject: reexport.c: Some Distros need the following include to avoid the
+ following error
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+Origin: https://git.linux-nfs.org/?p=steved/nfs-utils.git;a=commit;h=a2c95e4f557a71b482bb62bad6d93ddde51e5dc6
+Bug-Debian: https://bugs.debian.org/1073818
+
+reexport.c: In function ‘connect_fsid_service’:
+reexport.c:41:28: error: implicit declaration of function ‘offsetof’ [-Werror=implicit-function-declaration]
+ 41 | addr_len = offsetof(struct sockaddr_un, sun_path) + strlen(addr.sun_path);
+ | ^~~~~~~~
+reexport.c:19:1: note: ‘offsetof’ is defined in header ‘<stddef.h>’; did you forget to ‘#include <stddef.h>’?
+ 18 | #include "xlog.h"
+ +++ |+#include <stddef.h>
+ 19 |
+reexport.c:41:37: error: expected expression before ‘struct’
+ 41 | addr_len = offsetof(struct sockaddr_un, sun_path) + strlen(addr.sun_path);
+ | ^~~~~~
+cc1: some warnings being treated as errors
+
+Signed-off-by: Steve Dickson <steved@redhat.com>
+---
+ support/reexport/reexport.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/support/reexport/reexport.c
++++ b/support/reexport/reexport.c
+@@ -8,6 +8,7 @@
+ #include <sys/types.h>
+ #include <sys/vfs.h>
+ #include <errno.h>
++#include <stddef.h>
+
+ #include "nfsd_path.h"
+ #include "conffile.h"
diff --git a/debian/patches/series b/debian/patches/series
index ad5b435..82f738f 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,4 +2,5 @@ multiarch-kerberos-paths.patch
always-run-generator.patch
fsidd-call-anonymous-sockets-by-their-name-only-don-.patch
junction-export-cache-cast-to-a-type-with-a-known-si.patch
+reexport.c-Some-Distros-need-the-following-include-t.patch
progress-linux/0001-reexport-include.patch