summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..72ad4ba
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,38 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = support tools utils linux-nfs tests systemd
+
+MAINTAINERCLEANFILES = Makefile.in
+
+EXTRA_DIST = \
+ autogen.sh \
+ \
+ aclocal/bsdsignals.m4 \
+ aclocal/getrandom.m4 \
+ aclocal/nfs-utils.m4 \
+ aclocal/kerberos5.m4 \
+ aclocal/tcp-wrappers.m4 \
+ aclocal/libtirpc.m4 \
+ aclocal/libevent.m4 \
+ aclocal/libnfsidmap.m4 \
+ aclocal/rpcsec_vers.m4 \
+ aclocal/ipv6.m4
+
+ACLOCAL_AMFLAGS = -I aclocal
+
+install-data-hook:
+ if [ ! -d $(DESTDIR)$(statedir) ]; then mkdir -p $(DESTDIR)$(statedir); fi
+ touch $(DESTDIR)$(statedir)/etab; chmod 644 $(DESTDIR)$(statedir)/etab
+ touch $(DESTDIR)$(statedir)/rmtab; chmod 644 $(DESTDIR)$(statedir)/rmtab
+ mkdir -p $(DESTDIR)$(statdpath)/sm $(DESTDIR)$(statdpath)/sm.bak
+ touch $(DESTDIR)$(statdpath)/state
+ chmod go-rwx $(DESTDIR)$(statdpath)/sm $(DESTDIR)$(statdpath)/sm.bak $(DESTDIR)$(statdpath)/state
+ -chown $(statduser) $(DESTDIR)$(statdpath)/sm $(DESTDIR)$(statdpath)/sm.bak $(DESTDIR)$(statdpath)/state
+
+uninstall-hook:
+ rm -f $(DESTDIR)$(statedir)/xtab
+ rm $(DESTDIR)$(statedir)/etab
+ rm $(DESTDIR)$(statedir)/rmtab
+ rm $(DESTDIR)$(statdpath)/state