summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-09 13:08:38 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-09 13:08:38 +0000
commit9fe063bb3ef278a591e344caa78bee679536b7ee (patch)
treef589ace33354785090116341f7c702b6035b0868 /debian/rules
parentAdding upstream version 1.0.9. (diff)
downloadnftables-9fe063bb3ef278a591e344caa78bee679536b7ee.tar.xz
nftables-9fe063bb3ef278a591e344caa78bee679536b7ee.zip
Adding debian version 1.0.9-1.debian/1.0.9-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules46
1 files changed, 46 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e004562
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,46 @@
+#!/usr/bin/make -f
+
+ifeq (,$(filter terse,$(DEB_BUILD_OPTIONS)))
+export DH_VERBOSE=1
+endif
+export PYBUILD_NAME = nftables
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+include /usr/share/dpkg/architecture.mk
+include /usr/share/dpkg/pkg-info.mk
+
+pybuild_pkg := python3-$(PYBUILD_NAME)
+pybuild_opts := --buildsystem=pybuild -- --dir $(CURDIR)/py
+
+%:
+ dh $@ --with python3
+
+override_dh_auto_clean:
+ dh_auto_clean -N$(pybuild_pkg)
+ dh_auto_clean -p$(pybuild_pkg) $(pybuild_opts)
+
+override_dh_auto_configure:
+ dh_auto_configure -N$(pybuild_pkg) -- \
+ --with-xtables \
+ --with-json \
+ --with-python-bin=/usr/bin/python3 \
+ --with-cli=editline \
+ --
+ dh_auto_configure -p$(pybuild_pkg) $(pybuild_opts)
+
+override_dh_auto_build:
+ dh_auto_build -N$(pybuild_pkg)
+ dh_auto_build -p$(pybuild_pkg) $(pybuild_opts)
+
+override_dh_auto_install:
+ dh_auto_install -N$(pybuild_pkg)
+ dh_auto_install -p$(pybuild_pkg) $(pybuild_opts)
+
+execute_after_dh_fixperms:
+ chmod a+x debian/nftables/etc/nftables.conf
+
+override_dh_installsystemd:
+ dh_installsystemd --no-enable --no-start --restart-after-upgrade
+
+override_dh_installexamples:
+ dh_installexamples -XMakefile