summaryrefslogtreecommitdiffstats
path: root/llparse/examples/http/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'llparse/examples/http/Makefile')
-rw-r--r--llparse/examples/http/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/llparse/examples/http/Makefile b/llparse/examples/http/Makefile
new file mode 100644
index 0000000..323d2e3
--- /dev/null
+++ b/llparse/examples/http/Makefile
@@ -0,0 +1,11 @@
+CC ?= clang
+
+all: http
+
+http: main.c http_parser.bc
+ $(CC) -g3 -flto -Os -fvisibility=hidden -Wall -I. http_parser.c main.c -o $@
+
+http_parser.bc: index.ts
+ npx ts-node $<
+
+.PHONY = all