summaryrefslogtreecommitdiffstats
path: root/ccan/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 19:41:32 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 19:41:32 +0000
commitf26f66d866ba1a9f3204e6fdfe2b07e67b5492ad (patch)
treec953c007cbe4f60a147ab62f97937d58abb2e9ca /ccan/meson.build
parentInitial commit. (diff)
downloadnvme-cli-f26f66d866ba1a9f3204e6fdfe2b07e67b5492ad.tar.xz
nvme-cli-f26f66d866ba1a9f3204e6fdfe2b07e67b5492ad.zip
Adding upstream version 2.8.upstream/2.8
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ccan/meson.build')
-rw-r--r--ccan/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/ccan/meson.build b/ccan/meson.build
new file mode 100644
index 0000000..35d2b88
--- /dev/null
+++ b/ccan/meson.build
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+sources += files([
+ 'ccan/hash/hash.c',
+ 'ccan/htable/htable.c',
+ 'ccan/ilog/ilog.c',
+ 'ccan/likely/likely.c',
+ 'ccan/list/list.c',
+ 'ccan/str/debug.c',
+ 'ccan/str/str.c',
+ 'ccan/strset/strset.c',
+])
+
+if get_option('buildtype') == 'debug'
+ add_project_arguments('-DCCAN_LIST_DEBUG=1', language : ['c'])
+ add_project_arguments('-DCCAN_STR_DEBUG=1', language : ['c'])
+endif