summaryrefslogtreecommitdiffstats
path: root/ccan/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'ccan/meson.build')
-rw-r--r--ccan/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/ccan/meson.build b/ccan/meson.build
new file mode 100644
index 0000000..35d2b88
--- /dev/null
+++ b/ccan/meson.build
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+
+sources += files([
+ 'ccan/hash/hash.c',
+ 'ccan/htable/htable.c',
+ 'ccan/ilog/ilog.c',
+ 'ccan/likely/likely.c',
+ 'ccan/list/list.c',
+ 'ccan/str/debug.c',
+ 'ccan/str/str.c',
+ 'ccan/strset/strset.c',
+])
+
+if get_option('buildtype') == 'debug'
+ add_project_arguments('-DCCAN_LIST_DEBUG=1', language : ['c'])
+ add_project_arguments('-DCCAN_STR_DEBUG=1', language : ['c'])
+endif