summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..0df77f5
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,9 @@
+SUBDIRS = src man
+
+# The set of files to be formatted.
+FORMATSOURCES = src/*.c src/*.h
+format:
+ clang-format -i -style=file $(FORMATSOURCES)
+
+check-format:
+ clang-format -i -style=file $(FORMATSOURCES) && git diff --exit-code