summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 05:34:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 05:34:58 +0000
commitacb8fec29910b118f49f099c600ec9d673ca4cc0 (patch)
treef234dc756516bdb9eb32a5f11239da8c3099f227 /debian/rules
parentMerging upstream version 2.6.8+dfsg. (diff)
downloadopenldap-acb8fec29910b118f49f099c600ec9d673ca4cc0.tar.xz
openldap-acb8fec29910b118f49f099c600ec9d673ca4cc0.zip
Adding debian version 2.6.8+dfsg-1~exp1.debian/2.6.8+dfsg-1_exp1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 3 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 3fab06f..205241d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,7 +11,7 @@ export DEB_CFLAGS_MAINT_APPEND := -Wall -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
export DEB_BUILD_MAINT_OPTIONS := hardening=+all
# Expose maintainer address to build/mkversion (see debian/patches/set-maintainer-name)
-export DEB_MAINTAINER := $(shell sed -ne 's/Maintainer:\s\+//p' debian/control)
+export DEB_MAINTAINER := $(shell sed -ne 's/^Maintainer:\s\+//p' debian/control)
# Expose DEB_VERSION to build/version.sh (see debian/patches/debian-version)
export DEB_VERSION
@@ -27,7 +27,7 @@ ifneq ($(filter pkg.openldap.noslapd,$(DEB_BUILD_PROFILES)),)
CONFIG += --disable-slapd
endif
-CONTRIB_MODULES = autogroup lastbind passwd passwd/pbkdf2 passwd/sha2 smbk5pwd
+CONTRIB_MODULES = autogroup lastbind passwd passwd/pbkdf2 passwd/sha2 ppm smbk5pwd
# Ensure CC is set correctly for cross builds, unless it has already
# been set explicitly.
@@ -134,8 +134,7 @@ override_dh_fixperms-arch:
endif
override_dh_strip:
- dh_strip -pslapd --dbgsym-migration='slapd-dbg (<< 2.4.45+dfsg-1~)'
- dh_strip --remaining-packages
+ dh_strip
ifeq ($(filter pkg.openldap.noslapd,$(DEB_BUILD_PROFILES)),)
# hardlink these so not confined by apparmor; do this here and not
# in dh_link so that dh_strip doesn't get confused and put the wrong