summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 08:21:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 08:21:13 +0000
commit41c5a85983260edfb40aa4d436c3fae71de78b71 (patch)
tree4c62735688966c220e50776d5cf716fa42d6efe4 /debian/rules
parentAdding debian version 1:9.7p1-1. (diff)
downloadopenssh-41c5a85983260edfb40aa4d436c3fae71de78b71.tar.xz
openssh-41c5a85983260edfb40aa4d436c3fae71de78b71.zip
Adding debian version 1:9.7p1-2.debian/1%9.7p1-2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index fd9ab8d..cd4c27b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -108,6 +108,10 @@ ifeq ($(shell dpkg-vendor --is Ubuntu && echo yes) $(DEB_HOST_ARCH), yes i386)
BUILD_PACKAGES += -Nopenssh-tests
endif
+ifeq ($(DEB_HOST_ARCH_BITS)$(filter i386,$(DEB_HOST_ARCH_CPU)),32)
+ BUILD_PACKAGES += -Nssh-askpass-gnome
+endif
+
%:
dh $@ --with=runit $(BUILD_PACKAGES)
@@ -132,9 +136,11 @@ ifeq ($(filter noudeb,$(DEB_BUILD_PROFILES)),)
$(MAKE) -C debian/build-udeb $(PARALLEL) ASKPASS_PROGRAM='/usr/bin/ssh-askpass' ssh scp sftp sshd ssh-keygen
endif
+ifneq ($(DEB_HOST_ARCH_BITS)$(filter i386,$(DEB_HOST_ARCH_CPU)),32)
ifeq ($(filter pkg.openssh.nognome,$(DEB_BUILD_PROFILES)),)
$(MAKE) -C contrib gnome-ssh-askpass3 CC='$(CC) $(CPPFLAGS) $(CFLAGS) -Wall -Wl,--as-needed $(LDFLAGS)' PKG_CONFIG=$(PKG_CONFIG)
endif
+endif
override_dh_auto_build-indep: