summaryrefslogtreecommitdiffstats
path: root/etc/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:53:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:53:20 +0000
commite5a812082ae033afb1eed82c0f2df3d0f6bdc93f (patch)
treea6716c9275b4b413f6c9194798b34b91affb3cc7 /etc/Makefile.am
parentInitial commit. (diff)
downloadpacemaker-e5a812082ae033afb1eed82c0f2df3d0f6bdc93f.tar.xz
pacemaker-e5a812082ae033afb1eed82c0f2df3d0f6bdc93f.zip
Adding upstream version 2.1.6.upstream/2.1.6
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--etc/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/etc/Makefile.am b/etc/Makefile.am
new file mode 100644
index 0000000..b810f82
--- /dev/null
+++ b/etc/Makefile.am
@@ -0,0 +1,38 @@
+#
+# Copyright 2021-2022 the Pacemaker project contributors
+#
+# The version control history for this file may have further details.
+#
+# This source code is licensed under the GNU General Public License version 2
+# or later (GPLv2+) WITHOUT ANY WARRANTY.
+#
+
+MAINTAINERCLEANFILES = Makefile.in
+
+configdir = @CONFIGDIR@
+CONFIGS = crm_mon pacemaker
+
+if !BUILD_SYSTEMD
+initdir = $(INITDIR)
+init_SCRIPTS = init.d/pacemaker
+endif
+
+logrotatedir = $(sysconfdir)/logrotate.d
+logrotate_DATA = logrotate.d/pacemaker
+
+EXTRA_DIST = $(foreach f,$(CONFIGS),sysconfig/$(f))
+
+# Don't overwrite user's existing config files
+install-data-local:
+ $(AM_V_at)$(MKDIR_P) $(DESTDIR)$(configdir)
+ $(AM_V_at)for f in $(CONFIGS); do \
+ dest="$(DESTDIR)$(configdir)/$$f"; \
+ [ -e "$$dest" ] && dest="$$dest.new"; \
+ $(INSTALL_DATA) "$(srcdir)/sysconfig/$$f" "$$dest"; \
+ done
+
+uninstall-local:
+ $(AM_V_at)for f in $(CONFIGS); do \
+ dest="$(DESTDIR)$(configdir)/$$f"; \
+ rm -f "$$dest" "$$dest.new"; \
+ done