summaryrefslogtreecommitdiffstats
path: root/lib/cib/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:53:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:53:20 +0000
commite5a812082ae033afb1eed82c0f2df3d0f6bdc93f (patch)
treea6716c9275b4b413f6c9194798b34b91affb3cc7 /lib/cib/Makefile.am
parentInitial commit. (diff)
downloadpacemaker-e5a812082ae033afb1eed82c0f2df3d0f6bdc93f.tar.xz
pacemaker-e5a812082ae033afb1eed82c0f2df3d0f6bdc93f.zip
Adding upstream version 2.1.6.upstream/2.1.6
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'lib/cib/Makefile.am')
-rw-r--r--lib/cib/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/lib/cib/Makefile.am b/lib/cib/Makefile.am
new file mode 100644
index 0000000..721fca1
--- /dev/null
+++ b/lib/cib/Makefile.am
@@ -0,0 +1,28 @@
+#
+# Copyright 2004-2018 the Pacemaker project contributors
+#
+# The version control history for this file may have further details.
+#
+# This source code is licensed under the GNU General Public License version 2
+# or later (GPLv2+) WITHOUT ANY WARRANTY.
+#
+include $(top_srcdir)/mk/common.mk
+
+## libraries
+lib_LTLIBRARIES = libcib.la
+
+## SOURCES
+libcib_la_SOURCES = cib_ops.c cib_utils.c cib_client.c cib_native.c cib_attrs.c
+libcib_la_SOURCES += cib_file.c cib_remote.c
+
+libcib_la_LDFLAGS = -version-info 31:0:4
+libcib_la_CPPFLAGS = -I$(top_srcdir) $(AM_CPPFLAGS)
+
+libcib_la_CFLAGS = $(CFLAGS_HARDENED_LIB)
+libcib_la_LDFLAGS += $(LDFLAGS_HARDENED_LIB)
+
+libcib_la_LIBADD = $(top_builddir)/lib/pengine/libpe_rules.la \
+ $(top_builddir)/lib/common/libcrmcommon.la
+
+clean-generic:
+ rm -f *.log *.debug *.xml *~