summaryrefslogtreecommitdiffstats
path: root/lib/fencing/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:45:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:45:40 +0000
commit07d7f4cfa4b10de87a31b68191036ff446add675 (patch)
tree7162524d8aaf1aef62d2f4fa51f595ed113981ff /lib/fencing/Makefile.am
parentAdding upstream version 2.1.6. (diff)
downloadpacemaker-07d7f4cfa4b10de87a31b68191036ff446add675.tar.xz
pacemaker-07d7f4cfa4b10de87a31b68191036ff446add675.zip
Adding upstream version 2.1.7.upstream/2.1.7
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'lib/fencing/Makefile.am')
-rw-r--r--lib/fencing/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/lib/fencing/Makefile.am b/lib/fencing/Makefile.am
index a72b7d6..5302035 100644
--- a/lib/fencing/Makefile.am
+++ b/lib/fencing/Makefile.am
@@ -14,15 +14,19 @@ noinst_HEADERS = fencing_private.h
lib_LTLIBRARIES = libstonithd.la
-libstonithd_la_LDFLAGS = -version-info 34:3:8
+libstonithd_la_LDFLAGS = -version-info 34:4:8
libstonithd_la_CFLAGS = $(CFLAGS_HARDENED_LIB)
libstonithd_la_LDFLAGS += $(LDFLAGS_HARDENED_LIB)
-libstonithd_la_LIBADD = $(top_builddir)/lib/common/libcrmcommon.la
-libstonithd_la_LIBADD += $(top_builddir)/lib/services/libcrmservice.la
+libstonithd_la_LIBADD = $(top_builddir)/lib/services/libcrmservice.la
+libstonithd_la_LIBADD += $(top_builddir)/lib/common/libcrmcommon.la
-libstonithd_la_SOURCES = st_actions.c st_client.c st_output.c st_rhcs.c
+## Library sources (*must* use += format for bumplibs)
+libstonithd_la_SOURCES = st_actions.c
+libstonithd_la_SOURCES += st_client.c
if BUILD_LHA_SUPPORT
libstonithd_la_SOURCES += st_lha.c
endif
+libstonithd_la_SOURCES += st_output.c
+libstonithd_la_SOURCES += st_rhcs.c