summaryrefslogtreecommitdiffstats
path: root/mk/tap.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:53:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:53:20 +0000
commite5a812082ae033afb1eed82c0f2df3d0f6bdc93f (patch)
treea6716c9275b4b413f6c9194798b34b91affb3cc7 /mk/tap.mk
parentInitial commit. (diff)
downloadpacemaker-e5a812082ae033afb1eed82c0f2df3d0f6bdc93f.tar.xz
pacemaker-e5a812082ae033afb1eed82c0f2df3d0f6bdc93f.zip
Adding upstream version 2.1.6.upstream/2.1.6
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--mk/tap.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/mk/tap.mk b/mk/tap.mk
new file mode 100644
index 0000000..da67813
--- /dev/null
+++ b/mk/tap.mk
@@ -0,0 +1,31 @@
+#
+# Copyright 2021-2022 the Pacemaker project contributors
+#
+# The version control history for this file may have further details.
+#
+# This source code is licensed under the GNU General Public License version 2
+# or later (GPLv2+) WITHOUT ANY WARRANTY.
+#
+
+AM_TESTS_ENVIRONMENT= \
+ G_DEBUG=gc-friendly \
+ MALLOC_CHECK_=2 \
+ MALLOC_PERTURB_=$$(($${RANDOM:-256} % 256))
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/tests/tap-driver.sh
+LOG_COMPILER = $(top_srcdir)/tests/tap-test
+CLEANFILES = *.log *.trs
+
+WRAPPED = calloc \
+ endgrent \
+ fopen \
+ getenv \
+ getpid \
+ getgrent \
+ getpwnam_r \
+ readlink \
+ setenv \
+ setgrent \
+ strdup \
+ uname \
+ unsetenv
+LDFLAGS_WRAP = $(foreach fn,$(WRAPPED),-Wl,--wrap=$(fn))