summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:45:40 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 07:45:40 +0000
commit07d7f4cfa4b10de87a31b68191036ff446add675 (patch)
tree7162524d8aaf1aef62d2f4fa51f595ed113981ff /python/Makefile.am
parentAdding upstream version 2.1.6. (diff)
downloadpacemaker-07d7f4cfa4b10de87a31b68191036ff446add675.tar.xz
pacemaker-07d7f4cfa4b10de87a31b68191036ff446add675.zip
Adding upstream version 2.1.7.upstream/2.1.7
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 6cefb63..803fb0c 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -11,10 +11,16 @@ MAINTAINERCLEANFILES = Makefile.in
EXTRA_DIST = pylintrc
-SUBDIRS = pacemaker tests
+SUBDIRS = pacemaker \
+ tests
+.PHONY: check-local
check-local:
- $(PYTHON) -m unittest discover -v -s tests
+ if [ "x$(top_srcdir)" != "x$(top_builddir)" ]; then \
+ cp -r $(top_srcdir)/python/* $(abs_top_builddir)/python/; \
+ fi
+ PYTHONPATH=$(top_builddir)/python $(PYTHON) -m unittest discover -v -s $(top_builddir)/python/tests
+.PHONY: pylint
pylint:
pylint $(SUBDIRS)