summaryrefslogtreecommitdiffstats
path: root/python/tests
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:53:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:53:20 +0000
commite5a812082ae033afb1eed82c0f2df3d0f6bdc93f (patch)
treea6716c9275b4b413f6c9194798b34b91affb3cc7 /python/tests
parentInitial commit. (diff)
downloadpacemaker-e5a812082ae033afb1eed82c0f2df3d0f6bdc93f.tar.xz
pacemaker-e5a812082ae033afb1eed82c0f2df3d0f6bdc93f.zip
Adding upstream version 2.1.6.upstream/2.1.6
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'python/tests')
-rw-r--r--python/tests/Makefile.am12
-rw-r--r--python/tests/test_exitstatus.py14
2 files changed, 26 insertions, 0 deletions
diff --git a/python/tests/Makefile.am b/python/tests/Makefile.am
new file mode 100644
index 0000000..490b272
--- /dev/null
+++ b/python/tests/Makefile.am
@@ -0,0 +1,12 @@
+#
+# Copyright 2023 the Pacemaker project contributors
+#
+# The version control history for this file may have further details.
+#
+# This source code is licensed under the GNU General Public License version 2
+# or later (GPLv2+) WITHOUT ANY WARRANTY.
+#
+
+MAINTAINERCLEANFILES = Makefile.in
+
+EXTRA_DIST = $(wildcard test_*)
diff --git a/python/tests/test_exitstatus.py b/python/tests/test_exitstatus.py
new file mode 100644
index 0000000..571f6b4
--- /dev/null
+++ b/python/tests/test_exitstatus.py
@@ -0,0 +1,14 @@
+# These warnings are not useful in unit tests.
+# pylint: disable=missing-class-docstring,missing-function-docstring,missing-module-docstring
+
+__copyright__ = "Copyright 2023 the Pacemaker project contributors"
+__license__ = "GPLv2+"
+
+import unittest
+
+from pacemaker.exitstatus import ExitStatus
+
+class ExitStatusTestCase(unittest.TestCase):
+ def test_min_max(self):
+ self.assertEqual(ExitStatus.OK, 0)
+ self.assertEqual(ExitStatus.MAX, 255)