summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--debian/control6
-rw-r--r--debian/patches/Always-format-time_t-values-as-long-long.patch37
-rw-r--r--debian/patches/series1
4 files changed, 50 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index b300d13..210f497 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+pacemaker (2.1.6-5) unstable; urgency=medium
+
+ * [fba0e62] Annotate the versioned dpkg-dev build dependency with time64
+ * [2e0223d] New patch: Always format time_t values as long long
+ * [8b575c7] pkgconf superseded pkg-config
+
+ -- Ferenc Wágner <wferi@debian.org> Fri, 22 Mar 2024 17:48:44 +0100
+
pacemaker (2.1.6-4.1) unstable; urgency=medium
* Non-maintainer upload.
diff --git a/debian/control b/debian/control
index 5544d0b..e7c0ba2 100644
--- a/debian/control
+++ b/debian/control
@@ -5,13 +5,15 @@ Maintainer: Debian HA Maintainers <debian-ha-maintainers@alioth-lists.debian.net
Uploaders:
Ferenc Wágner <wferi@debian.org>,
Adrian Vondendriesch <adrian.vondendriesch@credativ.de>,
-Build-Depends: dpkg-dev (>= 1.22.5),
+Build-Depends:
cluster-glue-dev,
debhelper-compat (= 13),
dh-exec,
dh-sequence-python3,
# resource agent man pages are generated via:
docbook-xsl,
+# ensure that the time64 feature is enabled:
+ dpkg-dev (>= 1.22.5),
help2man,
libbz2-dev,
libcfg-dev (>= 1.99),
@@ -30,7 +32,7 @@ Build-Depends: dpkg-dev (>= 1.22.5),
libxml2-dev,
libxml2-utils,
libxslt1-dev,
- pkg-config,
+ pkgconf,
# 'pacemaker' is a pure Python package:
python3-all,
systemd [linux-any],
diff --git a/debian/patches/Always-format-time_t-values-as-long-long.patch b/debian/patches/Always-format-time_t-values-as-long-long.patch
new file mode 100644
index 0000000..444991b
--- /dev/null
+++ b/debian/patches/Always-format-time_t-values-as-long-long.patch
@@ -0,0 +1,37 @@
+From: =?utf-8?q?Ferenc_W=C3=A1gner?= <wferi@debian.org>
+Date: Fri, 22 Mar 2024 16:40:07 +0100
+Subject: Always format time_t values as long long
+MIME-Version: 1.0
+Content-Type: text/plain; charset="utf-8"
+Content-Transfer-Encoding: 8bit
+
+Conventionally it's signed long under the GNU C library, which is 32
+bits on 32-bit architectures, but Glibc provides the __TIME_BITS==64
+option, which makes it signed long long instead (64 bits) and makes no
+difference on 64-bit architectures [1]. This enables using the %llu
+conversion specifier uniformly across all supported architectures.
+This got exposed by Debian recently transitioning to 64-bit time_t [2].
+
+[1] https://sourceware.org/glibc/wiki/Y2038ProofnessDesign
+[2] https://wiki.debian.org/ReleaseGoals/64bit-time
+
+Signed-off-by: Ferenc Wágner <wferi@debian.org>
+---
+ daemons/fenced/fenced_remote.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/daemons/fenced/fenced_remote.c b/daemons/fenced/fenced_remote.c
+index dc67947..ef2237a 100644
+--- a/daemons/fenced/fenced_remote.c
++++ b/daemons/fenced/fenced_remote.c
+@@ -1042,8 +1042,8 @@ merge_duplicates(remote_fencing_op_t *op)
+ }
+ if ((other->total_timeout > 0)
+ && (now > (other->total_timeout + other->created))) {
+- crm_trace("%.8s not duplicate of %.8s: old (%ld vs. %ld + %d)",
+- op->id, other->id, now, other->created,
++ crm_trace("%.8s not duplicate of %.8s: old (%lld vs. %lld + %d)",
++ op->id, other->id, (long long)now, (long long)other->created,
+ other->total_timeout);
+ continue;
+ }
diff --git a/debian/patches/series b/debian/patches/series
index 0ad30a0..fb12979 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -7,3 +7,4 @@ Fix-typos-resouce-resource.patch
Remove-references-to-the-build-directory.patch
cts-do-not-capture-the-build-directory.patch
python-clean-up-the-__pycache__-directories.patch
+Always-format-time_t-values-as-long-long.patch