summaryrefslogtreecommitdiffstats
path: root/GNUmakefile
diff options
context:
space:
mode:
Diffstat (limited to 'GNUmakefile')
-rw-r--r--GNUmakefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/GNUmakefile b/GNUmakefile
index 8cb5d3e..8cac498 100644
--- a/GNUmakefile
+++ b/GNUmakefile
@@ -18,8 +18,6 @@ default: build
# directory if a relevant variable hasn't been defined.
abs_srcdir ?= $(shell pwd)
-GLIB_CFLAGS ?= $(pkg-config --cflags glib-2.0)
-
PACKAGE ?= pacemaker
.PHONY: init
@@ -40,8 +38,7 @@ USE_FILE = $(shell test -e rpm/Makefile || echo "-f Makefile.am")
$(PACKAGE).spec chroot dirty export mock rc release rpm rpmlint srpm:
$(MAKE) $(AM_MAKEFLAGS) -C rpm $(USE_FILE) "$@"
-.PHONY: mock-% rpm-% spec-% srpm-%
-mock-% rpm-% spec-% srpm-%:
+mock-% rpm-% spec-% srpm-%: FORCE
$(MAKE) $(AM_MAKEFLAGS) -C rpm $(USE_FILE) "$@"
## Development-related targets
@@ -59,3 +56,6 @@ clang $(COVERAGE_TARGETS) $(COVERITY_TARGETS) cppcheck indent:
COVLEVEL=$(COVLEVEL) \
CPPCHECK_ARGS=$(CPPCHECK_ARGS) \
-C devel "$@"
+
+.PHONY: FORCE
+FORCE: