summaryrefslogtreecommitdiffstats
path: root/daemons/execd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'daemons/execd/Makefile.am')
-rw-r--r--daemons/execd/Makefile.am43
1 files changed, 26 insertions, 17 deletions
diff --git a/daemons/execd/Makefile.am b/daemons/execd/Makefile.am
index 466f0df..ab8544f 100644
--- a/daemons/execd/Makefile.am
+++ b/daemons/execd/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2012-2021 the Pacemaker project contributors
+# Copyright 2012-2023 the Pacemaker project contributors
#
# The version control history for this file may have further details.
#
@@ -12,18 +12,20 @@ include $(top_srcdir)/mk/man.mk
halibdir = $(CRM_DAEMON_DIR)
-halib_PROGRAMS = pacemaker-execd cts-exec-helper
+halib_PROGRAMS = pacemaker-execd \
+ cts-exec-helper
EXTRA_DIST = pacemaker-remoted.8.inc
pacemaker_execd_CFLAGS = $(CFLAGS_HARDENED_EXE)
pacemaker_execd_LDFLAGS = $(LDFLAGS_HARDENED_EXE)
-pacemaker_execd_LDADD = $(top_builddir)/lib/common/libcrmcommon.la \
- $(top_builddir)/lib/services/libcrmservice.la \
- $(top_builddir)/lib/fencing/libstonithd.la
-pacemaker_execd_SOURCES = pacemaker-execd.c execd_commands.c \
- execd_alerts.c
+pacemaker_execd_LDADD = $(top_builddir)/lib/fencing/libstonithd.la
+pacemaker_execd_LDADD += $(top_builddir)/lib/services/libcrmservice.la
+pacemaker_execd_LDADD += $(top_builddir)/lib/common/libcrmcommon.la
+pacemaker_execd_SOURCES = pacemaker-execd.c \
+ execd_commands.c \
+ execd_alerts.c
if BUILD_REMOTE
sbin_PROGRAMS = pacemaker-remoted
@@ -34,22 +36,27 @@ initdir = $(INITDIR)
init_SCRIPTS = pacemaker_remote
endif
-pacemaker_remoted_CPPFLAGS = -DPCMK__COMPILE_REMOTE $(AM_CPPFLAGS)
+pacemaker_remoted_CPPFLAGS = -DPCMK__COMPILE_REMOTE \
+ $(AM_CPPFLAGS)
pacemaker_remoted_CFLAGS = $(CFLAGS_HARDENED_EXE)
pacemaker_remoted_LDFLAGS = $(LDFLAGS_HARDENED_EXE)
-pacemaker_remoted_LDADD = $(pacemaker_execd_LDADD) \
- $(top_builddir)/lib/lrmd/liblrmd.la
-pacemaker_remoted_SOURCES = $(pacemaker_execd_SOURCES) \
- remoted_tls.c remoted_pidone.c remoted_proxy.c
+pacemaker_remoted_LDADD = $(top_builddir)/lib/fencing/libstonithd.la
+pacemaker_remoted_LDADD += $(top_builddir)/lib/services/libcrmservice.la
+pacemaker_remoted_LDADD += $(top_builddir)/lib/lrmd/liblrmd.la
+pacemaker_remoted_LDADD += $(top_builddir)/lib/common/libcrmcommon.la
+pacemaker_remoted_SOURCES = $(pacemaker_execd_SOURCES) \
+ remoted_tls.c \
+ remoted_pidone.c \
+ remoted_proxy.c
endif
-cts_exec_helper_LDADD = $(top_builddir)/lib/common/libcrmcommon.la \
- $(top_builddir)/lib/lrmd/liblrmd.la \
- $(top_builddir)/lib/cib/libcib.la \
- $(top_builddir)/lib/services/libcrmservice.la \
- $(top_builddir)/lib/pengine/libpe_status.la
+cts_exec_helper_LDADD = $(top_builddir)/lib/pengine/libpe_status.la
+cts_exec_helper_LDADD += $(top_builddir)/lib/cib/libcib.la
+cts_exec_helper_LDADD += $(top_builddir)/lib/lrmd/liblrmd.la
+cts_exec_helper_LDADD += $(top_builddir)/lib/services/libcrmservice.la
+cts_exec_helper_LDADD += $(top_builddir)/lib/common/libcrmcommon.la
cts_exec_helper_SOURCES = cts-exec-helper.c
noinst_HEADERS = pacemaker-execd.h
@@ -59,6 +66,7 @@ CLEANFILES = $(man8_MANS)
# Always create a symlink for the old pacemaker_remoted name, so that bundle
# container images using a current Pacemaker will run on cluster nodes running
# Pacemaker 1 (>=1.1.17).
+.PHONY: install-exec-hook
install-exec-hook:
if BUILD_LEGACY_LINKS
cd $(DESTDIR)$(CRM_DAEMON_DIR) && rm -f lrmd && $(LN_S) pacemaker-execd lrmd
@@ -67,6 +75,7 @@ if BUILD_REMOTE
cd $(DESTDIR)$(sbindir) && rm -f pacemaker_remoted && $(LN_S) pacemaker-remoted pacemaker_remoted
endif
+.PHONY: uninstall-hook
uninstall-hook:
if BUILD_LEGACY_LINKS
cd $(DESTDIR)$(CRM_DAEMON_DIR) && rm -f lrmd