summaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--include/Makefile.am22
1 files changed, 12 insertions, 10 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index dfd7085..6618c7a 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2003-2019 the Pacemaker project contributors
+# Copyright 2003-2023 the Pacemaker project contributors
#
# The version control history for this file may have further details.
#
@@ -7,14 +7,15 @@
# or later (GPLv2+) WITHOUT ANY WARRANTY.
#
-MAINTAINERCLEANFILES = Makefile.in config.h.in
+MAINTAINERCLEANFILES = Makefile.in \
+ config.h.in
-noinst_HEADERS = config.h \
- crm_internal.h \
- doxygen.h \
- pacemaker.h \
- pacemaker-internal.h \
- portability.h \
+noinst_HEADERS = config.h \
+ crm_internal.h \
+ doxygen.h \
+ pacemaker.h \
+ pacemaker-internal.h \
+ portability.h \
gettext.h
pkginclude_HEADERS = crm_config.h
@@ -24,16 +25,17 @@ SUBDIRS = crm pcmki
GETTEXT_H ?= $(datadir)/gettext/gettext.h
+.PHONY: update-gettext
update-gettext:
@if [ ! -e "$(GETTEXT_H)" ]; then \
echo "$(GETTEXT_H) not found"; \
else \
cp "$(GETTEXT_H)" gettext.h; \
- git diff --quiet gettext.h 2>/dev/null; \
+ "$(GIT)" diff --quiet gettext.h 2>/dev/null; \
if [ $$? -eq 0 ]; then \
echo "No update needed"; \
else \
- git add gettext.h; \
+ "$(GIT)" add gettext.h; \
echo 'Review changes then run:'; \
echo 'git commit -m "Low: NLS: update gettext.h from upstream"'; \
fi \