summaryrefslogtreecommitdiffstats
path: root/include/crm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'include/crm/Makefile.am')
-rw-r--r--include/crm/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/include/crm/Makefile.am b/include/crm/Makefile.am
new file mode 100644
index 0000000..6dd52fd
--- /dev/null
+++ b/include/crm/Makefile.am
@@ -0,0 +1,22 @@
+#
+# Copyright 2004-2021 the Pacemaker project contributors
+#
+# The version control history for this file may have further details.
+#
+# This source code is licensed under the GNU General Public License version 2
+# or later (GPLv2+) WITHOUT ANY WARRANTY.
+#
+
+MAINTAINERCLEANFILES = Makefile.in
+
+headerdir=$(pkgincludedir)/crm
+
+header_HEADERS = cib.h cluster.h compatibility.h crm.h \
+ lrmd.h msg_xml.h services.h stonith-ng.h \
+ crm_compat.h \
+ msg_xml_compat.h \
+ services_compat.h
+
+noinst_HEADERS = lrmd_internal.h services_internal.h
+
+SUBDIRS = common pengine cib fencing cluster