summaryrefslogtreecommitdiffstats
path: root/include/crm/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--include/crm/common/Makefile.am73
1 files changed, 31 insertions, 42 deletions
diff --git a/include/crm/common/Makefile.am b/include/crm/common/Makefile.am
index 7d417e4..83a4197 100644
--- a/include/crm/common/Makefile.am
+++ b/include/crm/common/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2004-2022 the Pacemaker project contributors
+# Copyright 2004-2023 the Pacemaker project contributors
#
# The version control history for this file may have further details.
#
@@ -11,45 +11,34 @@ MAINTAINERCLEANFILES = Makefile.in
headerdir=$(pkgincludedir)/crm/common
-header_HEADERS = acl.h \
- agents.h \
- agents_compat.h \
- cib.h \
- ipc.h \
- ipc_attrd_internal.h \
- ipc_controld.h \
- ipc_pacemakerd.h \
- ipc_schedulerd.h \
- iso8601.h \
- logging.h \
- logging_compat.h \
- mainloop.h \
- mainloop_compat.h \
- nvpair.h \
- output.h \
- results.h \
- results_compat.h \
- util.h \
- util_compat.h \
- xml.h \
- xml_compat.h
+header_HEADERS = acl.h \
+ actions.h \
+ agents.h \
+ agents_compat.h \
+ cib.h \
+ ipc.h \
+ ipc_controld.h \
+ ipc_pacemakerd.h \
+ ipc_schedulerd.h \
+ iso8601.h \
+ logging.h \
+ logging_compat.h \
+ mainloop.h \
+ mainloop_compat.h \
+ nodes.h \
+ nvpair.h \
+ output.h \
+ resources.h \
+ results.h \
+ results_compat.h \
+ roles.h \
+ scheduler.h \
+ scheduler_types.h \
+ tags.h \
+ tickets.h \
+ util.h \
+ util_compat.h \
+ xml.h \
+ xml_compat.h
-noinst_HEADERS = acl_internal.h \
- alerts_internal.h \
- attrd_internal.h \
- cmdline_internal.h \
- health_internal.h \
- internal.h \
- io_internal.h \
- ipc_internal.h \
- iso8601_internal.h \
- lists_internal.h \
- logging_internal.h \
- messages_internal.h \
- options_internal.h \
- output_internal.h \
- remote_internal.h \
- results_internal.h \
- strings_internal.h \
- unittest_internal.h \
- xml_internal.h
+noinst_HEADERS = $(wildcard *internal.h)