summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..ed5bfa3
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,21 @@
+#
+# Copyright 2003-2021 the Pacemaker project contributors
+#
+# The version control history for this file may have further details.
+#
+# This source code is licensed under the GNU General Public License version 2
+# or later (GPLv2+) WITHOUT ANY WARRANTY.
+#
+MAINTAINERCLEANFILES = Makefile.in
+
+LIBS = cib lrmd service fencing cluster
+
+pkgconfig_DATA = $(LIBS:%=pacemaker-%.pc) \
+ libpacemaker.pc \
+ pacemaker.pc \
+ pacemaker-pe_rules.pc \
+ pacemaker-pe_status.pc
+
+EXTRA_DIST = $(pkgconfig_DATA:%=%.in)
+
+SUBDIRS = gnu common pengine cib services fencing lrmd cluster pacemaker