summaryrefslogtreecommitdiffstats
path: root/lib/common/tests/nvpair/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/common/tests/nvpair/Makefile.am')
-rw-r--r--lib/common/tests/nvpair/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/lib/common/tests/nvpair/Makefile.am b/lib/common/tests/nvpair/Makefile.am
new file mode 100644
index 0000000..7acaba3
--- /dev/null
+++ b/lib/common/tests/nvpair/Makefile.am
@@ -0,0 +1,18 @@
+#
+# Copyright 2021-2022 the Pacemaker project contributors
+#
+# The version control history for this file may have further details.
+#
+# This source code is licensed under the GNU General Public License version 2
+# or later (GPLv2+) WITHOUT ANY WARRANTY.
+#
+
+include $(top_srcdir)/mk/tap.mk
+include $(top_srcdir)/mk/unittest.mk
+
+# Add "_test" to the end of all test program names to simplify .gitignore.
+check_PROGRAMS = pcmk__xe_attr_is_true_test \
+ pcmk__xe_get_bool_attr_test \
+ pcmk__xe_set_bool_attr_test
+
+TESTS = $(check_PROGRAMS)