summaryrefslogtreecommitdiffstats
path: root/lib/common/tests/resources/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/common/tests/resources/Makefile.am')
-rw-r--r--lib/common/tests/resources/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/common/tests/resources/Makefile.am b/lib/common/tests/resources/Makefile.am
new file mode 100644
index 0000000..91e29a6
--- /dev/null
+++ b/lib/common/tests/resources/Makefile.am
@@ -0,0 +1,17 @@
+#
+# Copyright 2024 the Pacemaker project contributors
+#
+# The version control history for this file may have further details.
+#
+# This source code is licensed under the GNU General Public License version 2
+# or later (GPLv2+) WITHOUT ANY WARRANTY.
+#
+
+include $(top_srcdir)/mk/tap.mk
+include $(top_srcdir)/mk/unittest.mk
+
+# Add "_test" to the end of all test program names to simplify .gitignore.
+check_PROGRAMS = pcmk_resource_id_test \
+ pcmk_resource_is_managed_test
+
+TESTS = $(check_PROGRAMS)