summaryrefslogtreecommitdiffstats
path: root/lib/pengine/tests/native/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/pengine/tests/native/Makefile.am')
-rw-r--r--lib/pengine/tests/native/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/lib/pengine/tests/native/Makefile.am b/lib/pengine/tests/native/Makefile.am
new file mode 100644
index 0000000..5046ff1
--- /dev/null
+++ b/lib/pengine/tests/native/Makefile.am
@@ -0,0 +1,22 @@
+#
+# Copyright 2022 the Pacemaker project contributors
+#
+# The version control history for this file may have further details.
+#
+# This source code is licensed under the GNU General Public License version 2
+# or later (GPLv2+) WITHOUT ANY WARRANTY.
+#
+
+include $(top_srcdir)/mk/tap.mk
+include $(top_srcdir)/mk/unittest.mk
+
+AM_CPPFLAGS += -I$(top_srcdir)
+LDADD += $(top_builddir)/lib/pengine/libpe_status_test.la
+
+AM_TESTS_ENVIRONMENT += PCMK_CTS_CLI_DIR=$(top_srcdir)/cts/cli
+
+# Add "_test" to the end of all test program names to simplify .gitignore.
+check_PROGRAMS = native_find_rsc_test \
+ pe_base_name_eq_test
+
+TESTS = $(check_PROGRAMS)