summaryrefslogtreecommitdiffstats
path: root/lib/pengine/tests/utils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/pengine/tests/utils/Makefile.am')
-rw-r--r--lib/pengine/tests/utils/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/lib/pengine/tests/utils/Makefile.am b/lib/pengine/tests/utils/Makefile.am
new file mode 100644
index 0000000..4a3e8a2
--- /dev/null
+++ b/lib/pengine/tests/utils/Makefile.am
@@ -0,0 +1,21 @@
+#
+# Copyright 2022 the Pacemaker project contributors
+#
+# The version control history for this file may have further details.
+#
+# This source code is licensed under the GNU General Public License version 2
+# or later (GPLv2+) WITHOUT ANY WARRANTY.
+#
+
+include $(top_srcdir)/mk/tap.mk
+include $(top_srcdir)/mk/unittest.mk
+
+AM_CPPFLAGS += -I$(top_srcdir)/lib/pengine
+LDADD += $(top_builddir)/lib/pengine/libpe_status_test.la
+
+# Add "_test" to the end of all test program names to simplify .gitignore.
+check_PROGRAMS = \
+ pe__cmp_node_name_test \
+ pe__cmp_rsc_priority_test
+
+TESTS = $(check_PROGRAMS)