summaryrefslogtreecommitdiffstats
path: root/mk/tap.mk
diff options
context:
space:
mode:
Diffstat (limited to 'mk/tap.mk')
-rw-r--r--mk/tap.mk17
1 files changed, 10 insertions, 7 deletions
diff --git a/mk/tap.mk b/mk/tap.mk
index fd6d4e2..e06f9a8 100644
--- a/mk/tap.mk
+++ b/mk/tap.mk
@@ -1,5 +1,5 @@
#
-# Copyright 2021-2023 the Pacemaker project contributors
+# Copyright 2021-2024 the Pacemaker project contributors
#
# The version control history for this file may have further details.
#
@@ -7,15 +7,18 @@
# or later (GPLv2+) WITHOUT ANY WARRANTY.
#
-AM_TESTS_ENVIRONMENT= \
- G_DEBUG=gc-friendly \
- MALLOC_CHECK_=2 \
- MALLOC_PERTURB_=$$(($${RANDOM:-256} % 256))
+AM_TESTS_ENVIRONMENT = G_DEBUG=gc-friendly
+AM_TESTS_ENVIRONMENT += MALLOC_CHECK_=2
+AM_TESTS_ENVIRONMENT += MALLOC_PERTURB_=$$(($${RANDOM:-256} % 256))
+AM_TESTS_ENVIRONMENT += PCMK_CTS_CLI_DIR=$(top_srcdir)/cts/cli
+AM_TESTS_ENVIRONMENT += PCMK_schema_directory=$(top_builddir)/xml
+
LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/tests/tap-driver.sh
LOG_COMPILER = $(top_srcdir)/tests/tap-test
CLEANFILES = *.log *.trs
-WRAPPED = calloc \
+WRAPPED = abort \
+ calloc \
endgrent \
fopen \
getenv \
@@ -23,10 +26,10 @@ WRAPPED = calloc \
getgrent \
getpwnam_r \
readlink \
+ realloc \
setenv \
setgrent \
strdup \
- uname \
unsetenv
if WRAPPABLE_FOPEN64