summaryrefslogtreecommitdiffstats
path: root/mk
diff options
context:
space:
mode:
Diffstat (limited to 'mk')
-rw-r--r--mk/common.mk8
-rw-r--r--mk/release.mk21
-rw-r--r--mk/tap.mk13
3 files changed, 26 insertions, 16 deletions
diff --git a/mk/common.mk b/mk/common.mk
index ac360cc..4c92a0f 100644
--- a/mk/common.mk
+++ b/mk/common.mk
@@ -1,5 +1,5 @@
#
-# Copyright 2014-2021 the Pacemaker project contributors
+# Copyright 2014-2023 the Pacemaker project contributors
#
# The version control history for this file may have further details.
#
@@ -36,5 +36,7 @@ am__v_BOOK_1 =
MAINTAINERCLEANFILES = Makefile.in
-AM_CPPFLAGS = -I$(top_builddir)/include -I$(top_srcdir)/include \
- -I$(top_builddir)/libltdl -I$(top_srcdir)/libltdl
+AM_CPPFLAGS = -I$(top_builddir)/include \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir)/libltdl \
+ -I$(top_srcdir)/libltdl
diff --git a/mk/release.mk b/mk/release.mk
index 7d7259c..b10bcf0 100644
--- a/mk/release.mk
+++ b/mk/release.mk
@@ -1,5 +1,5 @@
#
-# Copyright 2008-2022 the Pacemaker project contributors
+# Copyright 2008-2023 the Pacemaker project contributors
#
# The version control history for this file may have further details.
#
@@ -13,10 +13,12 @@ COMMIT ?= HEAD
# TAG defaults to DIST when in a source distribution instead of a git checkout,
# the tag name if COMMIT is tagged, and the full commit ID otherwise.
-TAG ?= $(shell \
- T=$$(git describe --tags --exact-match '$(COMMIT)' 2>/dev/null); \
- [ -n "$${T}" ] && echo "$${T}" \
- || git log --pretty=format:%H -n 1 '$(COMMIT)' 2>/dev/null \
+TAG ?= $(shell \
+ T=$$("$(GIT)" describe --tags --exact-match '$(COMMIT)' \
+ 2>/dev/null); \
+ [ -n "$${T}" ] && echo "$${T}" \
+ || "$(GIT)" log --pretty=format:%H -n 1 '$(COMMIT)' \
+ 2>/dev/null \
|| echo DIST)
# If DIRTY=anything is passed to make, generated versions will end in ".mod"
@@ -24,7 +26,8 @@ TAG ?= $(shell \
# default.
DIRTY_EXT = $(shell [ -n "$(DIRTY)" ] \
&& [ "$(COMMIT)" == "HEAD" ] \
- && ! git diff-index --quiet HEAD -- 2>/dev/null \
+ && ! "$(GIT)" diff-index --quiet HEAD -- \
+ 2>/dev/null \
&& echo .mod)
# These can be used in case statements to avoid make interpreting parentheses
@@ -32,14 +35,14 @@ lparen = (
rparen = )
# This will be empty if not in a git checkout
-CHECKOUT = $(shell git rev-parse --git-dir 2>/dev/null)
+CHECKOUT = $(shell "$(GIT)" rev-parse --git-dir 2>/dev/null)
# VERSION is set by configure, but we allow some make targets to be run without
# running configure first, so set a reasonable default in that case.
VERSION ?= $(shell if [ -z "$(CHECKOUT)" ]; then \
echo 0.0.0; \
else \
- git tag -l \
+ "$(GIT)" tag -l \
| sed -n -e 's/^\(Pacemaker-[0-9.]*\)$$/\1/p' \
| sort -Vr | head -n 1; \
fi)
@@ -83,5 +86,5 @@ top_distdir = $(PACKAGE)-$(shell \
Pacemaker-*$(rparen) \
echo '$(TAG)' | cut -c11-;; \
*$(rparen) \
- git log --pretty=format:%h -n 1 '$(TAG)';; \
+ "$(GIT)" log --pretty=format:%h -n 1 '$(TAG)';; \
esac)$(DIRTY_EXT)
diff --git a/mk/tap.mk b/mk/tap.mk
index da67813..fd6d4e2 100644
--- a/mk/tap.mk
+++ b/mk/tap.mk
@@ -1,5 +1,5 @@
#
-# Copyright 2021-2022 the Pacemaker project contributors
+# Copyright 2021-2023 the Pacemaker project contributors
#
# The version control history for this file may have further details.
#
@@ -7,9 +7,9 @@
# or later (GPLv2+) WITHOUT ANY WARRANTY.
#
-AM_TESTS_ENVIRONMENT= \
- G_DEBUG=gc-friendly \
- MALLOC_CHECK_=2 \
+AM_TESTS_ENVIRONMENT= \
+ G_DEBUG=gc-friendly \
+ MALLOC_CHECK_=2 \
MALLOC_PERTURB_=$$(($${RANDOM:-256} % 256))
LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/tests/tap-driver.sh
LOG_COMPILER = $(top_srcdir)/tests/tap-test
@@ -28,4 +28,9 @@ WRAPPED = calloc \
strdup \
uname \
unsetenv
+
+if WRAPPABLE_FOPEN64
+WRAPPED += fopen64
+endif
+
LDFLAGS_WRAP = $(foreach fn,$(WRAPPED),-Wl,--wrap=$(fn))