summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
new file mode 100644
index 0000000..6cefb63
--- /dev/null
+++ b/python/Makefile.am
@@ -0,0 +1,20 @@
+#
+# Copyright 2023 the Pacemaker project contributors
+#
+# The version control history for this file may have further details.
+#
+# This source code is licensed under the GNU General Public License version 2
+# or later (GPLv2+) WITHOUT ANY WARRANTY.
+#
+
+MAINTAINERCLEANFILES = Makefile.in
+
+EXTRA_DIST = pylintrc
+
+SUBDIRS = pacemaker tests
+
+check-local:
+ $(PYTHON) -m unittest discover -v -s tests
+
+pylint:
+ pylint $(SUBDIRS)