summaryrefslogtreecommitdiffstats
path: root/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'python/Makefile.am')
-rw-r--r--python/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/python/Makefile.am b/python/Makefile.am
index 6cefb63..803fb0c 100644
--- a/python/Makefile.am
+++ b/python/Makefile.am
@@ -11,10 +11,16 @@ MAINTAINERCLEANFILES = Makefile.in
EXTRA_DIST = pylintrc
-SUBDIRS = pacemaker tests
+SUBDIRS = pacemaker \
+ tests
+.PHONY: check-local
check-local:
- $(PYTHON) -m unittest discover -v -s tests
+ if [ "x$(top_srcdir)" != "x$(top_builddir)" ]; then \
+ cp -r $(top_srcdir)/python/* $(abs_top_builddir)/python/; \
+ fi
+ PYTHONPATH=$(top_builddir)/python $(PYTHON) -m unittest discover -v -s $(top_builddir)/python/tests
+.PHONY: pylint
pylint:
pylint $(SUBDIRS)