summaryrefslogtreecommitdiffstats
path: root/rpm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'rpm/Makefile.am')
-rw-r--r--rpm/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/rpm/Makefile.am b/rpm/Makefile.am
index 2388ad6..9a454e5 100644
--- a/rpm/Makefile.am
+++ b/rpm/Makefile.am
@@ -162,7 +162,12 @@ $(RPM_SPEC_DIR)/$(PACKAGE).spec: spec-clean pacemaker.spec.in
-e 's/^\(%global commit_abbrev \).*/\1$(SPEC_ABBREV)/' \
-e "s/PACKAGE_DATE/$$(date +'%a %b %d %Y')/" \
-e 's/PACKAGE_VERSION/$(SPEC_RELEASE_NO)-$(SPECVERSION)/' \
- > "$@"
+ > "$@"; \
+ if echo "$$(rpmlint --help 2>&1)" | grep -q "ignore-unused-rpmlintrc"; then \
+ rpmlint --ignore-unused-rpmlintrc --file rpmlintrc "$@"; \
+ else \
+ rpmlint --file rpmlintrc "$@"; \
+ fi
.PHONY: spec $(PACKAGE).spec
spec $(PACKAGE).spec: $(RPM_SPEC_DIR)/$(PACKAGE).spec
@@ -191,10 +196,6 @@ rpm: srpm
rpm-clean: spec-clean srpm-clean
-if [ -n "$(RPM_CLEAN)" ]; then rm -rf $(RPM_CLEAN); fi
-.PHONY: rpmlint
-rpmlint: $(RPM_SPEC_DIR)/$(PACKAGE).spec
- rpmlint -f rpmlintrc "$<"
-
.PHONY: rpm-dep
rpm-dep: $(RPM_SPEC_DIR)/$(PACKAGE).spec
sudo yum-builddep "$(RPM_SPEC_DIR)/$(PACKAGE).spec"