summaryrefslogtreecommitdiffstats
path: root/rpm
diff options
context:
space:
mode:
Diffstat (limited to 'rpm')
-rw-r--r--rpm/Makefile.am11
-rw-r--r--rpm/pacemaker.spec.in11
-rw-r--r--rpm/rpmlintrc9
3 files changed, 15 insertions, 16 deletions
diff --git a/rpm/Makefile.am b/rpm/Makefile.am
index 2388ad6..9a454e5 100644
--- a/rpm/Makefile.am
+++ b/rpm/Makefile.am
@@ -162,7 +162,12 @@ $(RPM_SPEC_DIR)/$(PACKAGE).spec: spec-clean pacemaker.spec.in
-e 's/^\(%global commit_abbrev \).*/\1$(SPEC_ABBREV)/' \
-e "s/PACKAGE_DATE/$$(date +'%a %b %d %Y')/" \
-e 's/PACKAGE_VERSION/$(SPEC_RELEASE_NO)-$(SPECVERSION)/' \
- > "$@"
+ > "$@"; \
+ if echo "$$(rpmlint --help 2>&1)" | grep -q "ignore-unused-rpmlintrc"; then \
+ rpmlint --ignore-unused-rpmlintrc --file rpmlintrc "$@"; \
+ else \
+ rpmlint --file rpmlintrc "$@"; \
+ fi
.PHONY: spec $(PACKAGE).spec
spec $(PACKAGE).spec: $(RPM_SPEC_DIR)/$(PACKAGE).spec
@@ -191,10 +196,6 @@ rpm: srpm
rpm-clean: spec-clean srpm-clean
-if [ -n "$(RPM_CLEAN)" ]; then rm -rf $(RPM_CLEAN); fi
-.PHONY: rpmlint
-rpmlint: $(RPM_SPEC_DIR)/$(PACKAGE).spec
- rpmlint -f rpmlintrc "$<"
-
.PHONY: rpm-dep
rpm-dep: $(RPM_SPEC_DIR)/$(PACKAGE).spec
sudo yum-builddep "$(RPM_SPEC_DIR)/$(PACKAGE).spec"
diff --git a/rpm/pacemaker.spec.in b/rpm/pacemaker.spec.in
index c279f88..66ad1da 100644
--- a/rpm/pacemaker.spec.in
+++ b/rpm/pacemaker.spec.in
@@ -1,5 +1,5 @@
#
-# Copyright 2008-2023 the Pacemaker project contributors
+# Copyright 2008-2024 the Pacemaker project contributors
#
# The version control history for this file may have further details.
#
@@ -204,7 +204,7 @@
## Distro-specific configuration choices
### Use 2.0-style output when other distro packages don't support current output
-%if 0%{?fedora} || ( 0%{?rhel} && 0%{?rhel} <= 8 )
+%if ( 0%{?fedora} && 0%{?fedora} <=35 ) || ( 0%{?rhel} && 0%{?rhel} <= 8 )
%global compat20 --enable-compat-2.0
%endif
@@ -412,6 +412,11 @@ Requires(pre): %{pkgname_shadow_utils}
Requires: %{name}-schemas = %{version}-%{release}
# sbd 1.4.0+ supports the libpe_status API for pe_working_set_t
Conflicts: sbd < 1.4.0
+%if ( 0%{?fedora} && 0%{?fedora} <=35 ) || ( 0%{?rhel} && 0%{?rhel} <= 8 )
+Conflicts: pcs >= 0.11
+%else
+Conflicts: pcs < 0.11
+%endif
%description -n %{pkgname_pcmk_libs}
Pacemaker is an advanced, scalable High-Availability cluster resource
@@ -769,6 +774,7 @@ exit 0
%endif
%{_sbindir}/fence_watchdog
+%doc %{_mandir}/man7/pacemaker-based.*
%doc %{_mandir}/man7/pacemaker-controld.*
%doc %{_mandir}/man7/pacemaker-schedulerd.*
%doc %{_mandir}/man7/pacemaker-fenced.*
@@ -849,6 +855,7 @@ exit 0
%{ocf_root}/resource.d/pacemaker
%doc %{_mandir}/man7/*pacemaker*
+%exclude %{_mandir}/man7/pacemaker-based.*
%exclude %{_mandir}/man7/pacemaker-controld.*
%exclude %{_mandir}/man7/pacemaker-schedulerd.*
%exclude %{_mandir}/man7/pacemaker-fenced.*
diff --git a/rpm/rpmlintrc b/rpm/rpmlintrc
index 9104182..2e24773 100644
--- a/rpm/rpmlintrc
+++ b/rpm/rpmlintrc
@@ -6,18 +6,9 @@ addFilter("E: hardcoded-library-path in /usr/lib/os-release")
# When building developer packages
addFilter("W: invalid-url Source0:")
-addFilter("W: unstripped-binary-or-object")
-addFilter("W: incoherent-version-in-changelog")
-addFilter("E: changelog-time-in-future")
# rpmlint doesn't like logrotate script being in pacemaker-cli package
addFilter("E: incoherent-logrotate-file /etc/logrotate.d/pacemaker")
# pacemaker_remote scriptlets use a state file
addFilter("W: dangerous-command-in-%(pre|postun|posttrans) rm")
-
-# We should really use "pacemaker-remote", but we don't
-addFilter("W: incoherent-init-script-name pacemaker_remote")
-
-# Some scriptlets have code for systemd systems only
-addFilter("W: empty-%(post|pre|preun|postun|posttrans)")