summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--tests/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 96019de..8601e1b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2020-2022 the Pacemaker project contributors
+# Copyright 2020-2023 the Pacemaker project contributors
#
# The version control history for this file may have further details.
#
@@ -8,14 +8,15 @@
#
# tap-test is copied from /usr/share/automake-*/tap-driver.sh.
-EXTRA_DIST = tap-driver.sh \
- tap-test \
+EXTRA_DIST = tap-driver.sh \
+ tap-test \
test-headers.sh
+.PHONY: check
check: check-headers
.PHONY: check-headers
check-headers:
CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" CC="$(CC)" \
- CXX="$(CXX)" CPPFLAGS="$(CPPFLAGS)" LIBS="$(LIBS)" \
+ CXX="$(CXX)" CPPFLAGS="$(CPPFLAGS) -I$(top_builddir)/include" LIBS="$(LIBS)" \
SRCDIR="$(top_srcdir)" sh "$(srcdir)/test-headers.sh"