summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..96019de
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,21 @@
+#
+# Copyright 2020-2022 the Pacemaker project contributors
+#
+# The version control history for this file may have further details.
+#
+# This source code is licensed under the GNU General Public License version 2
+# or later (GPLv2+) WITHOUT ANY WARRANTY.
+#
+
+# tap-test is copied from /usr/share/automake-*/tap-driver.sh.
+EXTRA_DIST = tap-driver.sh \
+ tap-test \
+ test-headers.sh
+
+check: check-headers
+
+.PHONY: check-headers
+check-headers:
+ CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" CC="$(CC)" \
+ CXX="$(CXX)" CPPFLAGS="$(CPPFLAGS)" LIBS="$(LIBS)" \
+ SRCDIR="$(top_srcdir)" sh "$(srcdir)/test-headers.sh"