summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 04:31:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 04:31:18 +0000
commitafec1c7556c0b8f0c6683dc414ab5c5c9c6f605e (patch)
tree958b863c1ac3493987265d8f04e7a241edb8161b /Makefile
parentAdding debian version 0.11. (diff)
downloadpackage-notes-afec1c7556c0b8f0c6683dc414ab5c5c9c6f605e.tar.xz
package-notes-afec1c7556c0b8f0c6683dc414ab5c5c9c6f605e.zip
Merging upstream version 0.12.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 13de305..46f82e9 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,16 @@
all:
+dlopen-notes.1: dlopen-notes.py docs/dlopen-description.man Makefile
+ argparse-manpage \
+ --output=docs/$@ \
+ --pyfile=$< \
+ --function=make_parser \
+ --project-name=package-notes \
+ --include=docs/dlopen-description.man
+
install:
install -m 755 -D dlopen-notes.py $(DESTDIR)/usr/bin/dlopen-notes
+ install -m 644 -D docs/dlopen-notes.1 $(DESTDIR)/usr/share/man/man1/dlopen-notes.1
check:
make -C test check