summaryrefslogtreecommitdiffstats
path: root/test/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 04:25:26 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-12 04:25:26 +0000
commit5ceacb82619304a784634ee5bb0ad0ea4e54ab3c (patch)
tree3b5e6fd489662166a27092ed563714d2a678576a /test/Makefile
parentInitial commit. (diff)
downloadpackage-notes-5ceacb82619304a784634ee5bb0ad0ea4e54ab3c.tar.xz
package-notes-5ceacb82619304a784634ee5bb0ad0ea4e54ab3c.zip
Adding upstream version 0.10~exp.upstream/0.10_exp
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'test/Makefile')
-rw-r--r--test/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/test/Makefile b/test/Makefile
new file mode 100644
index 0000000..b91a4ac
--- /dev/null
+++ b/test/Makefile
@@ -0,0 +1,9 @@
+notes: notes.c
+ $(CC) -o $@ $+ $(CFLAGS) $(LDFLAGS) $(LDLIBS)
+
+check: notes
+ python3 -m pytest test.py
+
+clean:
+ rm -f notes
+ rm -rf __pycache__/