summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 09:43:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 09:43:15 +0000
commitfe3977a32ee06b7499aa9e2ef6d67daae821d449 (patch)
treeb2513d52b6cb89426ad47a3afdc85041b3faad4e /debian/rules
parentAdding upstream version 20240222+ds. (diff)
downloadparallel-fe3977a32ee06b7499aa9e2ef6d67daae821d449.tar.xz
parallel-fe3977a32ee06b7499aa9e2ef6d67daae821d449.zip
Adding debian version 20240222+ds-2.debian/20240222+ds-2debian
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..e224148
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,19 @@
+#!/usr/bin/make -f
+%:
+ dh $@
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ echo "Upstream does not provide test suite"
+endif
+
+execute_before_dh_auto_configure:
+ cp debian/pod2rst-fix src/
+
+override_dh_install:
+ dh_install
+ for pl in `grep -Rl '#!/usr/bin/env[[:space:]]\+perl' debian/*/usr/*` ; do \
+ sed -i '1s?^#!/usr/bin/env[[:space:]]\+perl?#!/usr/bin/perl?' $${pl} ; \
+ done
+ find debian -name env_parallel.pdksh -delete
+ find debian -name env_parallel.ash -delete