summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 19:21:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 19:31:01 +0000
commitfb4c838c8e2900f5d746555b0c3893314543ebec (patch)
tree290b00ce792b7b8918c268ab454e10f6529bd282 /debian/rules
parentReleasing progress-linux version 3.6-3.1~progress7.99u1. (diff)
downloadparted-fb4c838c8e2900f5d746555b0c3893314543ebec.tar.xz
parted-fb4c838c8e2900f5d746555b0c3893314543ebec.zip
Merging debian version 3.6-4.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules12
1 files changed, 3 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index de1fd95..1b875dd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,7 +12,7 @@ DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
export DEB_BUILD_MAINT_OPTIONS := hardening=+all
-CONFFLAGS := --sbindir=/sbin --enable-mtrace --enable-shared
+CONFFLAGS := --sbindir=/usr/sbin --enable-mtrace --enable-shared
CONFFLAGS += --disable-gcc-warnings
# Enable device-mapper only on Linux
@@ -26,7 +26,7 @@ endif
CONFFLAGS_UDEB := $(CONFFLAGS)
# Options specific to the udeb build.
-CONFFLAGS_UDEB += ac_cv_header_execinfo_h=no --libdir=/lib
+CONFFLAGS_UDEB += ac_cv_header_execinfo_h=no --libdir=/usr/lib
CONFFLAGS_UDEB += --disable-static --without-readline
%:
@@ -62,7 +62,7 @@ override_dh_auto_install:
$(MAKE) -C build-udeb/libparted install DESTDIR=$(CURDIR)/debian/tmp-udeb
$(MAKE) -C build-udeb/parted install DESTDIR=$(CURDIR)/debian/tmp-udeb
rm -f debian/tmp/usr/lib/*/*.la
- rm -f debian/tmp-udeb/lib/*.la debian/tmp-udeb/lib/*.so
+ rm -f debian/tmp-udeb/usr/lib/*.la debian/tmp-udeb/usr/lib/*.so
override_dh_install:
dh_install -Nparted-udeb -Nlibparted2-udeb -Nlibparted-fs-resize0-udeb
@@ -75,12 +75,6 @@ override_dh_installdocs-indep:
dh_installdocs -pparted-doc --doc-main-package=libparted2
dh_installdocs --remaining-packages
-override_dh_strip:
- dh_strip -plibparted2 --ddeb-migration='libparted2-dbg (<< 3.2-11~)'
- dh_strip -plibparted-fs-resize0 \
- --ddeb-migration='libparted-fs-resize0-dbg (<< 3.2-11~)'
- dh_strip -Nlibparted2 -Nlibparted-fs-resize0
-
override_dh_makeshlibs:
dh_makeshlibs -plibparted2 --add-udeb=libparted2-udeb -- -c4
dh_makeshlibs -plibparted-fs-resize0 --add-udeb=libparted-fs-resize0-udeb -- -c4