summaryrefslogtreecommitdiffstats
path: root/doc/C/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--doc/C/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/doc/C/Makefile.am b/doc/C/Makefile.am
new file mode 100644
index 0000000..c5f2a77
--- /dev/null
+++ b/doc/C/Makefile.am
@@ -0,0 +1,28 @@
+## Process this file with automake to produce Makefile.in
+
+dist_man8_MANS = \
+ parted.8 \
+ partprobe.8
+
+.PHONY: updatepo
+# Update the POT in srcdir
+# Make sure the update does not only consist in a new POT-Creation-Date
+# Don't do anything if $(srcdir) is read-only (i.e., for "make distcheck").
+updatepo:
+ cd $(srcdir); \
+ test -w . || exit 0; \
+ test -d po || mkdir po; \
+ for name in $(dist_man8_MANS); do \
+ echo $$name; \
+ test -f po/$$name.pot || touch po/$$name.pot; \
+ cp po/$$name.pot po/$$name.new.pot; \
+ po4a-updatepo -f man -m $$name -p po/$$name.new.pot; \
+ diff -I '^\"POT-Creation-Date: ' po/$$name.pot po/$$name.new.pot 2>&1 > /dev/null; \
+ if [ $$? ]; then \
+ mv po/$$name.new.pot po/$$name.pot; \
+ else \
+ rm -f po/$$name.new.pot; \
+ fi; \
+ done
+
+dist-hook: updatepo