summaryrefslogtreecommitdiffstats
path: root/src/interfaces/libpq/test/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 19:46:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-16 19:46:48 +0000
commit311bcfc6b3acdd6fd152798c7f287ddf74fa2a98 (patch)
tree0ec307299b1dada3701e42f4ca6eda57d708261e /src/interfaces/libpq/test/Makefile
parentInitial commit. (diff)
downloadpostgresql-15-upstream.tar.xz
postgresql-15-upstream.zip
Adding upstream version 15.4.upstream/15.4upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/interfaces/libpq/test/Makefile')
-rw-r--r--src/interfaces/libpq/test/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/interfaces/libpq/test/Makefile b/src/interfaces/libpq/test/Makefile
new file mode 100644
index 0000000..75ac08f
--- /dev/null
+++ b/src/interfaces/libpq/test/Makefile
@@ -0,0 +1,24 @@
+# src/interfaces/libpq/test/Makefile
+
+PGFILEDESC = "libpq test program"
+PGAPPICON = win32
+
+subdir = src/interfaces/libpq/test
+top_builddir = ../../../..
+include $(top_builddir)/src/Makefile.global
+
+ifeq ($(PORTNAME), win32)
+LDFLAGS += -lws2_32
+endif
+
+override CPPFLAGS := -I$(libpq_srcdir) $(CPPFLAGS)
+LDFLAGS_INTERNAL += $(libpq_pgport)
+
+PROGS = libpq_testclient libpq_uri_regress
+
+all: $(PROGS)
+
+$(PROGS): $(WIN32RES)
+
+clean distclean maintainer-clean:
+ rm -f $(PROGS) *.o