summaryrefslogtreecommitdiffstats
path: root/contrib/xml2/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:44:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:44:03 +0000
commit293913568e6a7a86fd1479e1cff8e2ecb58d6568 (patch)
treefc3b469a3ec5ab71b36ea97cc7aaddb838423a0c /contrib/xml2/Makefile
parentInitial commit. (diff)
downloadpostgresql-16-293913568e6a7a86fd1479e1cff8e2ecb58d6568.tar.xz
postgresql-16-293913568e6a7a86fd1479e1cff8e2ecb58d6568.zip
Adding upstream version 16.2.upstream/16.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--contrib/xml2/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/contrib/xml2/Makefile b/contrib/xml2/Makefile
new file mode 100644
index 0000000..0d703fe
--- /dev/null
+++ b/contrib/xml2/Makefile
@@ -0,0 +1,26 @@
+# contrib/xml2/Makefile
+
+MODULE_big = pgxml
+OBJS = \
+ $(WIN32RES) \
+ xpath.o \
+ xslt_proc.o
+
+EXTENSION = xml2
+DATA = xml2--1.1.sql xml2--1.0--1.1.sql
+PGFILEDESC = "xml2 - XPath querying and XSLT"
+
+REGRESS = xml2
+
+SHLIB_LINK += $(filter -lxslt, $(LIBS)) -lxml2
+
+ifdef USE_PGXS
+PG_CONFIG = pg_config
+PGXS := $(shell $(PG_CONFIG) --pgxs)
+include $(PGXS)
+else
+subdir = contrib/xml2
+top_builddir = ../..
+include $(top_builddir)/src/Makefile.global
+include $(top_srcdir)/contrib/contrib-global.mk
+endif