summaryrefslogtreecommitdiffstats
path: root/src/bin/pg_ctl/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:44:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:44:03 +0000
commit293913568e6a7a86fd1479e1cff8e2ecb58d6568 (patch)
treefc3b469a3ec5ab71b36ea97cc7aaddb838423a0c /src/bin/pg_ctl/Makefile
parentInitial commit. (diff)
downloadpostgresql-16-293913568e6a7a86fd1479e1cff8e2ecb58d6568.tar.xz
postgresql-16-293913568e6a7a86fd1479e1cff8e2ecb58d6568.zip
Adding upstream version 16.2.upstream/16.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/bin/pg_ctl/Makefile')
-rw-r--r--src/bin/pg_ctl/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/src/bin/pg_ctl/Makefile b/src/bin/pg_ctl/Makefile
new file mode 100644
index 0000000..4b6d47a
--- /dev/null
+++ b/src/bin/pg_ctl/Makefile
@@ -0,0 +1,53 @@
+#-------------------------------------------------------------------------
+#
+# Makefile for src/bin/pg_ctl
+#
+# Portions Copyright (c) 1996-2023, PostgreSQL Global Development Group
+# Portions Copyright (c) 1994, Regents of the University of California
+#
+# src/bin/pg_ctl/Makefile
+#
+#-------------------------------------------------------------------------
+
+PGFILEDESC = "pg_ctl - starts/stops/restarts the PostgreSQL server"
+PGAPPICON=win32
+
+subdir = src/bin/pg_ctl
+top_builddir = ../../..
+include $(top_builddir)/src/Makefile.global
+
+# On Windows, we need to link with libpq, just for use of pqexpbuffer;
+# but let's not pull that in on platforms where we don't need it.
+ifeq ($(PORTNAME), win32)
+override CPPFLAGS := -I$(libpq_srcdir) $(CPPFLAGS)
+LDFLAGS_INTERNAL += $(libpq_pgport)
+SUBMAKE_LIBPQ := submake-libpq
+endif
+
+OBJS = \
+ $(WIN32RES) \
+ pg_ctl.o
+
+all: pg_ctl
+
+pg_ctl: $(OBJS) | submake-libpgport $(SUBMAKE_LIBPQ)
+ $(CC) $(CFLAGS) $(OBJS) $(LDFLAGS) $(LDFLAGS_EX) $(LIBS) -o $@$(X)
+
+install: all installdirs
+ $(INSTALL_PROGRAM) pg_ctl$(X) '$(DESTDIR)$(bindir)/pg_ctl$(X)'
+
+installdirs:
+ $(MKDIR_P) '$(DESTDIR)$(bindir)'
+
+uninstall:
+ rm -f '$(DESTDIR)$(bindir)/pg_ctl$(X)'
+
+clean distclean maintainer-clean:
+ rm -f pg_ctl$(X) $(OBJS)
+ rm -rf tmp_check
+
+check:
+ $(prove_check)
+
+installcheck:
+ $(prove_installcheck)