summaryrefslogtreecommitdiffstats
path: root/src/bin/psql/nls.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:44:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:44:03 +0000
commit293913568e6a7a86fd1479e1cff8e2ecb58d6568 (patch)
treefc3b469a3ec5ab71b36ea97cc7aaddb838423a0c /src/bin/psql/nls.mk
parentInitial commit. (diff)
downloadpostgresql-16-293913568e6a7a86fd1479e1cff8e2ecb58d6568.tar.xz
postgresql-16-293913568e6a7a86fd1479e1cff8e2ecb58d6568.zip
Adding upstream version 16.2.upstream/16.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/bin/psql/nls.mk')
-rw-r--r--src/bin/psql/nls.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/src/bin/psql/nls.mk b/src/bin/psql/nls.mk
new file mode 100644
index 0000000..cf0b800
--- /dev/null
+++ b/src/bin/psql/nls.mk
@@ -0,0 +1,30 @@
+# src/bin/psql/nls.mk
+CATALOG_NAME = psql
+GETTEXT_FILES = $(FRONTEND_COMMON_GETTEXT_FILES) \
+ command.c \
+ common.c \
+ copy.c \
+ crosstabview.c \
+ help.c \
+ input.c \
+ large_obj.c \
+ mainloop.c \
+ psqlscanslash.c \
+ startup.c \
+ describe.c \
+ sql_help.h \
+ sql_help.c \
+ tab-complete.c \
+ variables.c \
+ ../../fe_utils/cancel.c \
+ ../../fe_utils/print.c \
+ ../../fe_utils/psqlscan.c \
+ ../../common/exec.c \
+ ../../common/fe_memutils.c \
+ ../../common/username.c \
+ ../../common/wait_error.c \
+ ../../port/thread.c
+GETTEXT_TRIGGERS = $(FRONTEND_COMMON_GETTEXT_TRIGGERS) \
+ HELP0 HELPN N_ simple_prompt simple_prompt_extended
+GETTEXT_FLAGS = $(FRONTEND_COMMON_GETTEXT_FLAGS) \
+ HELPN:1:c-format