summaryrefslogtreecommitdiffstats
path: root/src/test/examples/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:44:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 13:44:03 +0000
commit293913568e6a7a86fd1479e1cff8e2ecb58d6568 (patch)
treefc3b469a3ec5ab71b36ea97cc7aaddb838423a0c /src/test/examples/Makefile
parentInitial commit. (diff)
downloadpostgresql-16-293913568e6a7a86fd1479e1cff8e2ecb58d6568.tar.xz
postgresql-16-293913568e6a7a86fd1479e1cff8e2ecb58d6568.zip
Adding upstream version 16.2.upstream/16.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/test/examples/Makefile')
-rw-r--r--src/test/examples/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/test/examples/Makefile b/src/test/examples/Makefile
new file mode 100644
index 0000000..a67f456
--- /dev/null
+++ b/src/test/examples/Makefile
@@ -0,0 +1,22 @@
+#
+# Makefile for example programs
+#
+
+subdir = src/test/examples
+top_builddir = ../../..
+include $(top_builddir)/src/Makefile.global
+
+ifeq ($(PORTNAME), win32)
+LDFLAGS += -lws2_32
+endif
+
+override CPPFLAGS := -I$(libpq_srcdir) $(CPPFLAGS)
+LDFLAGS_INTERNAL += $(libpq_pgport)
+
+
+PROGS = testlibpq testlibpq2 testlibpq3 testlibpq4 testlo testlo64
+
+all: $(PROGS)
+
+clean distclean maintainer-clean:
+ rm -f $(PROGS) *.o