summaryrefslogtreecommitdiffstats
path: root/contrib/auth_delay/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/auth_delay/meson.build')
-rw-r--r--contrib/auth_delay/meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/contrib/auth_delay/meson.build b/contrib/auth_delay/meson.build
new file mode 100644
index 0000000..f2b2da0
--- /dev/null
+++ b/contrib/auth_delay/meson.build
@@ -0,0 +1,17 @@
+# Copyright (c) 2022-2023, PostgreSQL Global Development Group
+
+auth_delay_sources = files(
+ 'auth_delay.c',
+)
+
+if host_system == 'windows'
+ auth_delay_sources += rc_lib_gen.process(win32ver_rc, extra_args: [
+ '--NAME', 'auth_delay',
+ '--FILEDESC', 'auth_delay - delay authentication failure reports',])
+endif
+
+auth_delay = shared_module('auth_delay',
+ auth_delay_sources,
+ kwargs: contrib_mod_args,
+)
+contrib_targets += auth_delay