summaryrefslogtreecommitdiffstats
path: root/contrib/oid2name/meson.build
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--contrib/oid2name/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/contrib/oid2name/meson.build b/contrib/oid2name/meson.build
new file mode 100644
index 0000000..171d2d2
--- /dev/null
+++ b/contrib/oid2name/meson.build
@@ -0,0 +1,29 @@
+# Copyright (c) 2022-2023, PostgreSQL Global Development Group
+
+oid2name_sources = files(
+ 'oid2name.c',
+)
+
+if host_system == 'windows'
+ oid2name_sources += rc_bin_gen.process(win32ver_rc, extra_args: [
+ '--NAME', 'oid2name',
+ '--FILEDESC', 'oid2name - examine the file structure',])
+endif
+
+oid2name = executable('oid2name',
+ oid2name_sources,
+ dependencies: [frontend_code, libpq],
+ kwargs: default_bin_args,
+)
+contrib_targets += oid2name
+
+tests += {
+ 'name': 'oid2name',
+ 'sd': meson.current_source_dir(),
+ 'bd': meson.current_build_dir(),
+ 'tap': {
+ 'tests': [
+ 't/001_basic.pl',
+ ],
+ },
+}