summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 13 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 6804f94..f23ea6e 100644
--- a/meson.build
+++ b/meson.build
@@ -8,7 +8,7 @@
project('postgresql',
['c'],
- version: '16.2',
+ version: '16.3',
license: 'PostgreSQL',
# We want < 0.56 for python 3.5 compatibility on old platforms. EPEL for
@@ -237,10 +237,20 @@ elif host_system == 'darwin'
cflags += ['-isysroot', pg_sysroot]
ldflags += ['-isysroot', pg_sysroot]
endif
+
# meson defaults to -Wl,-undefined,dynamic_lookup for modules, which we
# don't want because a) it's different from what we do for autoconf, b) it
- # causes warnings starting in macOS Ventura
- ldflags_mod += ['-Wl,-undefined,error']
+ # causes warnings in macOS Ventura. But using -Wl,-undefined,error causes a
+ # warning starting in Sonoma. So only add -Wl,-undefined,error if it does
+ # not cause a warning.
+ if cc.has_multi_link_arguments('-Wl,-undefined,error', '-Werror')
+ ldflags_mod += '-Wl,-undefined,error'
+ endif
+
+ # Starting in Sonoma, the linker warns about the same library being
+ # linked twice. Which can easily happen when multiple dependencies
+ # depend on the same library. Quiesce the ill considered warning.
+ ldflags += cc.get_supported_link_arguments('-Wl,-no_warn_duplicate_libraries')
elif host_system == 'freebsd'
sema_kind = 'unnamed_posix'
@@ -2422,7 +2432,6 @@ func_checks = [
['posix_fadvise'],
['posix_fallocate'],
['ppoll'],
- ['pstat'],
['pthread_barrier_wait', {'dependencies': [thread_dep]}],
['pthread_is_threaded_np', {'dependencies': [thread_dep]}],
['sem_init', {'dependencies': [rt_dep, thread_dep], 'skip': sema_kind != 'unnamed_posix', 'define': false}],